I restored a database backup and get no results in ApexSQL Log

Applies to
ApexSQL Log

Summary
This article shows what to do when there are no results after a database backup is restored in ApexSQL Log

Symptoms
The original database is in full recovery mode. The restored database is restored from a database backup and there are no results in the Main Grid

Cause
The cause for this problem is that the restored database has its own online transaction log, and it doesn’t hold information on the transactions that have occurred prior to restoring it.

Resolution
Original transaction log file needs to be added to the auditing process in order to get the proper results. Create a transaction log backup of original database, or detach databases .LDF file and add them (there is no need to add both, just add backup or detached .LDF) to the process of restored database auditing.

Message showing that connection to the database has failed

About ApexSQL Log
ApexSQL Log is a SQL Server auditing and recovery solution. Use ApexSQL Log to recover data, undo INSERT, UPDATE and DELETE commands and audit schema changes. Read the transaction log to find out who created, changed or dropped a database object

Last updated
June 28, 2018